This forum is no longer active, and the posting feature has been disabled.

Please visit our new Community page to continue the ShipStation Community discussions at https://help.shipstation.com/hc/en-us/community/topics

This new Community page is integrated directly with our help center and knowledge base, which will provide better access to help resources and a direct post-to-support ticket pipeline for any users that need official technical support!

Please note: All topics are available to view for all, but you must be logged into your ShipStation account to post community forum content or comment on posts.

Error While Making POST Request to /orders/createorder

Hello! I have a custom piece of software integrating with the ShipStation API. Have spent all morning on figuring out why some of our orders are going through to the ShipStation and some aren't. We're giving our users the ability to select a specific carrier/service OR indicate to the shipper to use the cheapest available option.

When the user selects cheapest we omit the "carrierCode" and "serviceCode" params in the body of the request. Historically this has worked fine (since they're optional fields) but starting on March 22nd requests that omit those fields throw an "Object reference not set to an instance of an object" error. We'll remove the ability for users to select "Cheapest" as an option for the time being but I just wanted to bring this bug to your attention.

Thank you!
Hunter
Sign In or Register to comment.