This forum is no longer active, and the posting feature has been disabled.

Please visit our new Community page to continue the ShipStation Community discussions at https://help.shipstation.com/hc/en-us/community/topics

This new Community page is integrated directly with our help center and knowledge base, which will provide better access to help resources and a direct post-to-support ticket pipeline for any users that need official technical support!

Please note: All topics are available to view for all, but you must be logged into your ShipStation account to post community forum content or comment on posts.

Any have problem with Google Cloud printing?

Hello, I am having an issue with printing through Google Cloud. For some reason the Zebra label printer settings do not translate to google cloud. When I download a .pdf and print the .pdf I still have to manually change the printer to the Zebra label printer but the settings are correct and everything prints fine. When I print outside of shipstation with google cloud the "printer settings' window pops up and allow for manual changes like any other print job. It's just through shipstation that the issue arrises.

Anyone else have this problem? Find a solution?

Answers

  • jbarbjbarb Moderator
    A Keeper of the Keys
    Hello, I have seen strange issues like this with Google Cloud print with several of our users. Depending on if you have a PC or Mac, the instructions are very different. If you tell me what you have I can help you with some instructions that may fix your issue.
  • Etsie538Etsie538 Member
    An Apprentice
    Hello, thanks for responding. I have a PC. I thought I had the issue fixed for awhile but then out of nowhere it started not printing again. Now, when I go to print the labels using the drop down menu and clicking on the Zebra printer it shows "sending print job" but nothing prints. So, I then download the .pdf, change the printer manually and it prints fine. I have tried deleting all printers except the Zebra from Cloud, but they mysteriously reappear. The inconsistency of the whole process is getting ridiculous.

    Hope you can assist quickly.

    Thank you.
  • jbarbjbarb Moderator
    A Keeper of the Keys
    What I have seen using Google Cloud Print is it tends to lose communication with the service that it installs on your PC to run in the background and then you have to open up Chrome and go to your Settings, then Google Cloud Print and either use the Disconnect Printers button or if that is not shown use the Add Printers button. I have also noticed that if you add a thermal printer, then make changes to the settings, the new settings will not take effect on Google Cloud Print, it is like it saves the settings of the printer at the point you added it so you have to remove the printer and re-add it for the changes to take effect. Besides these issues I have run Google Cloud Print successfully with the occasional loss of communication with the service about 2-3 times a month. Please let me know if you have any other questions or if this does not resolve your issues. The only other option is to turn Google Cloud Print off in ShipStation and print from the print preview window which is just like 2-3 more clicks.
  • mysterygirlmysterygirl Member
    An Apprentice
    I have the same problem-- but describing the "loss of communication" as something that happens 2-3 times a month is not really accurate. I lose communication with Google 2-3 times A DAY on some days and lose connection AT LEAST once every day. I print labels everyday, too, so maybe that's the difference-- I notice the loss of connection more.

    Right now, for example, ShipStation can't even see all of the printers that are in my Google Print account. I've sent in a support ticket but was looking for other solutions and saw this exchange, thought I would weigh in and ask for help.

    The connection between SS and GCP is really, really shaky. I usually go through the hassle of re-establishing communication and then things work fine (although I usually have to log in and out of shipstation, re-load my printers into Google, re-attach my new account and "new" printers with Shipstation and THEN I can print. It's not just a 2-3 click fix).

    But, today? Nope! I had to download labels and then go to Google Cloud Print myself and print them manually (as a file upload) since SS does not even see the printers that are in my Google account.

    Clearly I am doing something wrong, right? It can't just be like this!

    If anyone knows what's going on, I would love some help!

    Thanks!
  • mysterygirlmysterygirl Member
    An Apprentice
    It's me again!

    Still no resolution to this problem. I have contacted support three times about this issue, but no one has helped. They keep just telling me how to set up Google print or to plug my printers into my computer instead of the wireless router (did that, no effect).

    I have printers correctly set up in my Google Cloud Print account. I've even set them up in several different accounts, just to make sure it was not a problem with Google or with one specific account.

    When I connect ShipStation to GCP, it says everything is connected, but my printers are NOT LISTED. If I try a different Google account, some of my printers show up, but not all of them do.

    Is there anyone out there who knows what's going on and what has caused ShipStation to stop talking correctly to GCP????

    Anyone else having trouble with Shipstation's printing?

    Anyone have ideas on what to try?
  • overlordcomputeroverlordcomputer Member
    An Apprentice
    I am having the same issues you are with GCP and SS - the whole approach is rubbish. Why can't we print directly to connected printers again? I know I can save a PDF and THEN print, but that is a hassle for tons of orders. The GCP approach is not working for me at all.

    What Mysterygirl described is exactly what I am seeing - nothing. SS - eliminate the GCP and let us direct print please! Not being able to do so is a major problem and may cause me to dump this service before the end of the 30 day trial period since having to do "work arounds" to print orders should not be a solution when I pay a monthly fee.

    Sort this printing issue out please.
  • JasonJason Moderator
    A Keeper of the Keys
    We have just started a beta test of a direct print feature, however it currently only works on Windows. If you are interested, please open a support case and ask for beta access to this feature. Thanks!
Sign In or Register to comment.