New? Watch our welcome video [here], which goes over the basics of logging in and participating in the forums. Then, check out the [Rules] and our [video] about the features of the forum.

New Order detail screen

So the newly re-arranged order detail screen made its debut today. Cant say Im impressed. There are a zillion other things that need to be fixed or improved yet the developers see fit to play musical chairs with the order screen that was one area that was fine the way it was. Now the shipping options are hidden so there is no way a busy shipper will remember to open up the options to review what is needed. sheesh......

Comments

  • bhrichardbhrichard Member
    A Usual Suspect
    Same issue here. I came to the forums just to post the our shipping department is not happy about the shipping options for previous orders being wiped out. It was helpful to see the exact shipment configuration that an order previously had.

    Agree with how there are other things that need to be fixed or improved, but time was spent on this. Yet they comment on the idea portal that time is a limited resource.
  • wrapworkswrapworks Member
    An Apprentice
    > @Gene@3BC9E said:
    > So the newly re-arranged order detail screen made its debut today. Cant say Im impressed. There are a zillion other things that need to be fixed or improved yet the developers see fit to play musical chairs with the order screen that was one area that was fine the way it was. Now the shipping options are hidden so there is no way a busy shipper will remember to open up the options to review what is needed. sheesh......

    Am I missing something? Shipping options are hidden?
    I'm just unhappy that this morning we are having to put weights in for flat rate envelopes!
  • Gene@3BC9EGene@3BC9E Member
    A Usual Suspect
    bhrichard said:

    Same issue here. I came to the forums just to post the our shipping department is not happy about the shipping options for previous orders being wiped out. It was helpful to see the exact shipment configuration that an order previously had.

    Agree with how there are other things that need to be fixed or improved, but time was spent on this. Yet they comment on the idea portal that time is a limited resource.

    Didn't notice that till you mentioned it. This is a fiasco. Totally unacceptable. I was just looking at preship orders. It amazes me that the Lead Developer still has a job. They have been rolling out changes for years without any beta testing and using our businesses as guinea pigs.
  • Ben@3B520Ben@3B520 Member
    An Apprentice
    I hate this thing! I thought my PC settings got screwed up or something. It looks terrible, information I don't care about is stretched out filling the screen with large empty space in between , I have to scroll down to find the Create Label button. I have macros set up to work with that screen that I now have to re-build.
  • Ryan@49392Ryan@49392 Member
    An Apprentice
    I am not a fan of the new layout either. I have found that when you start to fill out shipping weight and dimensions its such a pain. For example if you were to fill out the size information it will not allow you to enter the next number until updates or it reverts back to zero. for example if the package is 25x16x2 you have to enter 25, wait a couple seconds for total to update, then 16, wait a couple seconds for total to update, then 2, wait a couple seconds for total to update. If you don't wait, the entered number turns to zero and you have to enter it again.

    That and the order notes are not accessible at a glance. you have to scroll down!
  • Kris@61E55Kris@61E55 Member
    An Apprentice
    Am I missing something? I am not noticing any difference in the Order Detail page (and I've been using SS for 7+ months).
    Untitled-1.jpg
    1306 x 1009 - 332K
  • Gene@3BC9EGene@3BC9E Member
    A Usual Suspect
    You are late to the party. They reverted back to the old screen. Hopefully for good.
  • Kris@61E55Kris@61E55 Member
    An Apprentice
    Crazy. I have shipped things every day for at least the past 30 days and didn't see any change. Maybe it was an error in rendering the markup?
Sign In or Register to comment.